// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^[^\-]*)\W([^\s]*)\s+([^\s]*)\s+([^\s]*)\s+([^\s]*)\s+(.*$)").unwrap();
let string = "Jul 28 08:27:40 Mon-iWEB-R03-APS-01 authproc1_auth01 {\"actn\":76,\"pckId\":\"7a25f9c4bb39cacf\",\"sId\":\"354669705072900392110145246\",\"utId\":106854,\"did\":\"60b265bd68322e8c\",\"dvcc\":3,\"vsn\":\"139\"}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}