using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?xm)^
(?:
[^;""'']+
(?:
(?:'[^'']*')|
(?:""[^""]*"")
)*
)*+
(;\N+)";
string input = @"$x = ""a"" & ""b"" ; com
; test
; ""test""
; ""test'
; 'test'
; 'test""
$x='' ; chaîne ""vide""
$x="" ; chaîne ""vide""
$x="" ; chaîne 'vide'
$x = ""aa;aa"" ; Comment-line
$x = ""a"" ;$x='b'
$x=' '' '';'' "";"" ""'' ''"" ""''""' ; chaîne ""vide""
$x=' '' '';'' "";"" ""'' ''"" ""''""' ; chaîne 'vide'
$x="" ' ';' "";"" ""' '"" ""'"""" ; chaîne ""vide""
$x="" ' ';' "";"" ""' '"" ""'"""" ; chaîne 'vide'
$x = 'bb;b'
$x = ""bb;b""
$x = "" "" & ""bb""
;;;;
; ; ;"";'
; test";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}