package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?xm)^
(?:
[^;"'']+
(?:
(?:'[^'']*')|
(?:"[^"]*")
)*
)*+
(;\N+)`)
var str = `$x = "a" & "b" ; com
; test
; "test"
; "test'
; 'test'
; 'test"
$x='' ; chaîne "vide"
$x="" ; chaîne "vide"
$x="" ; chaîne 'vide'
$x = "aa;aa" ; Comment-line
$x = "a" ;$x='b'
$x=' '' '';'' ";" "'' ''" "''"' ; chaîne "vide"
$x=' '' '';'' ";" "'' ''" "''"' ; chaîne 'vide'
$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne "vide"
$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne 'vide'
$x = 'bb;b'
$x = "bb;b"
$x = " " & "bb"
;;;;
; ; ;";'
; test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}