const regex = /(?xm)^
(?:
[^;"'']+
(?:
(?:'[^'']*')|
(?:"[^"]*")
)*
)*+
(;\N+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?xm)^
(?:
[^;"\'\']+
(?:
(?:\'[^\'\']*\')|
(?:"[^"]*")
)*
)*+
(;\\N+)', 'mg')
const str = `\$x = "a" & "b" ; com
; test
; "test"
; "test'
; 'test'
; 'test"
\$x='' ; chaîne "vide"
\$x="" ; chaîne "vide"
\$x="" ; chaîne 'vide'
\$x = "aa;aa" ; Comment-line
\$x = "a" ;\$x='b'
\$x=' '' '';'' ";" "'' ''" "''"' ; chaîne "vide"
\$x=' '' '';'' ";" "'' ''" "''"' ; chaîne 'vide'
\$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne "vide"
\$x=" ' ';' "";"" ""' '"" ""'""" ; chaîne 'vide'
\$x = 'bb;b'
\$x = "bb;b"
\$x = " " & "bb"
;;;;
; ; ;";'
; test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}