import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xm)^\n"
+ "(?:\n"
+ " [^;\"'']+\n"
+ " (?:\n"
+ " (?:'[^'']*')|\n"
+ " (?:\"[^\"]*\")\n"
+ " )*\n"
+ ")*+\n"
+ "(;\\N+)";
final String string = "$x = \"a\" & \"b\" ; com\n\n"
+ "; test\n"
+ "; \"test\"\n"
+ "; \"test'\n"
+ "; 'test'\n"
+ "; 'test\"\n"
+ "$x='' ; chaîne \"vide\"\n"
+ "$x=\"\" ; chaîne \"vide\"\n"
+ "$x=\"\" ; chaîne 'vide'\n"
+ "$x = \"aa;aa\" ; Comment-line\n"
+ "$x = \"a\" ;$x='b'\n"
+ "$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne \"vide\"\n"
+ "$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne 'vide'\n"
+ "$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne \"vide\"\n"
+ "$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne 'vide'\n\n\n"
+ "$x = 'bb;b'\n"
+ "$x = \"bb;b\"\n"
+ "$x = \" \" & \"bb\"\n\n"
+ ";;;;\n"
+ "; ; ;\";'\n"
+ " ; test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}