// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)(?xm)^
(?:
[^;"'']+
(?:
(?:'[^'']*')|
(?:"[^"]*")
)*
)*+
(;\N+)"#).unwrap();
let string = "$x = \"a\" & \"b\" ; com
; test
; \"test\"
; \"test'
; 'test'
; 'test\"
$x='' ; chaîne \"vide\"
$x=\"\" ; chaîne \"vide\"
$x=\"\" ; chaîne 'vide'
$x = \"aa;aa\" ; Comment-line
$x = \"a\" ;$x='b'
$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne \"vide\"
$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne 'vide'
$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne \"vide\"
$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne 'vide'
$x = 'bb;b'
$x = \"bb;b\"
$x = \" \" & \"bb\"
;;;;
; ; ;\";'
; test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}