#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=([A-Z]\d[A-Z]\s*\d[A-Z]\d))"
Local $sString = "SOMETEXTJ9H5G0L2J0OTHERSTUFF" & @CRLF & _
"SOMETEXTA0A 0A0OTHERSTUFF" & @CRLF & _
"SOMETEXTB1A0A0A0OTHERSTUFFB2A B2BOTHER"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")