import re
regex = re.compile(r"(?=([A-Z]\d[A-Z]\s*\d[A-Z]\d))", flags=re.MULTILINE)
test_str = ("SOMETEXTJ9H5G0L2J0OTHERSTUFF\n"
"SOMETEXTA0A 0A0OTHERSTUFF\n"
"SOMETEXTB1A0A0A0OTHERSTUFFB2A B2BOTHER")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")