import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=([A-Z]\\d[A-Z]\\s*\\d[A-Z]\\d))";
final String string = "SOMETEXTJ9H5G0L2J0OTHERSTUFF\n"
+ "SOMETEXTA0A 0A0OTHERSTUFF\n"
+ "SOMETEXTB1A0A0A0OTHERSTUFFB2A B2BOTHER";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}