using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=([A-Z]\d[A-Z]\s*\d[A-Z]\d))";
string input = @"SOMETEXTJ9H5G0L2J0OTHERSTUFF
SOMETEXTA0A 0A0OTHERSTUFF
SOMETEXTB1A0A0A0OTHERSTUFFB2A B2BOTHER";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}