import Foundation
let pattern = #"(?=([A-Z]\d[A-Z]\s*\d[A-Z]\d))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SOMETEXTJ9H5G0L2J0OTHERSTUFF
SOMETEXTA0A 0A0OTHERSTUFF
SOMETEXTB1A0A0A0OTHERSTUFFB2A B2BOTHER
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)