#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w]+\@[\w]+\.[^\d\W]+"
Local $sString = "a@a.a" & @CRLF & _
"1@a.a" & @CRLF & _
"a@1.a" & @CRLF & _
"a@a.1" & @CRLF & _
"aa@aa.aa" & @CRLF & _
"1a@aa.aa" & @CRLF & _
"aa@1a.aa" & @CRLF & _
"aa@aa.1a" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")