$re = '/[\w]+\@[\w]+\.[^\d\W]+/';
$str = 'a@a.a
1@a.a
a@1.a
a@a.1
aa@aa.aa
1a@aa.aa
aa@1a.aa
aa@aa.1a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);