import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w]+\\@[\\w]+\\.[^\\d\\W]+";
final String string = "a@a.a\n"
+ "1@a.a\n"
+ "a@1.a\n"
+ "a@a.1\n"
+ "aa@aa.aa\n"
+ "1a@aa.aa\n"
+ "aa@1a.aa\n"
+ "aa@aa.1a\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}