package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w]+\@[\w]+\.[^\d\W]+`)
var str = `a@a.a
1@a.a
a@1.a
a@a.1
aa@aa.aa
1a@aa.aa
aa@1a.aa
aa@aa.1a
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}