re = /[\w]+\@[\w]+\.[^\d\W]+/
str = 'a@a.a
1@a.a
a@1.a
a@a.1
aa@aa.aa
1a@aa.aa
aa@1a.aa
aa@aa.1a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end