#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{3,10}$)[a-z\d_.-]*[a-z][a-z\d_.-]*$" & @CRLF & _
""
Local $sString = "my_dog.has" & @CRLF & _
"12345g789" & @CRLF & _
"_.-_.-_.-" & @CRLF & _
"my_dog.hasfleas" & @CRLF & _
"my_doG.has" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")