$re = '/^(?=.{3,10}$)[a-z\d_.-]*[a-z][a-z\d_.-]*$
/m';
$str = 'my_dog.has
12345g789
_.-_.-_.-
my_dog.hasfleas
my_doG.has
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);