re = /^(?=.{3,10}$)[a-z\d_.-]*[a-z][a-z\d_.-]*$
/m
str = 'my_dog.has
12345g789
_.-_.-_.-
my_dog.hasfleas
my_doG.has
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end