using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{3,10}$)[a-z\d_.-]*[a-z][a-z\d_.-]*$
";
string input = @"my_dog.has
12345g789
_.-_.-_.-
my_dog.hasfleas
my_doG.has
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}