import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{3,10}$)[a-z\\d_.-]*[a-z][a-z\\d_.-]*$\n";
final String string = "my_dog.has\n"
+ "12345g789\n"
+ "_.-_.-_.-\n"
+ "my_dog.hasfleas\n"
+ "my_doG.has\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}