const regex = /^(?=.{3,10}$)[a-z\d_.-]*[a-z][a-z\d_.-]*$
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{3,10}$)[a-z\\d_.-]*[a-z][a-z\\d_.-]*$
', 'gm')
const str = `my_dog.has
12345g789
_.-_.-_.-
my_dog.hasfleas
my_doG.has
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}