using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=accord[^)]*)\s";
string substitution = @"%20";
string input = @"A scripture reference like [Luke 2:12, 16](accord://read/?Luke 2:12, 16) should be clickable.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}