import re
regex = re.compile(r"(?<=accord[^)]*)\s", flags=re.MULTILINE)
test_str = "A scripture reference like [Luke 2:12, 16](accord://read/?Luke 2:12, 16) should be clickable."
subst = "%20"
result = regex.sub(subst, test_str)
if result:
print(result)