$re = '/(?<=accord[^)]*)\s/m';
$str = 'A scripture reference like [Luke 2:12, 16](accord://read/?Luke 2:12, 16) should be clickable.';
$subst = "%20";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;