re = /(?<=accord[^)]*)\s/m
str = 'A scripture reference like [Luke 2:12, 16](accord://read/?Luke 2:12, 16) should be clickable.'
subst = '%20'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result