const regex = /(?<=accord[^)]*)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=accord[^)]*)\\s', 'gm')
const str = `A scripture reference like [Luke 2:12, 16](accord://read/?Luke 2:12, 16) should be clickable.`;
const subst = `%20`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);