import Foundation
let pattern = #"(?<=accord[^)]*)\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"A scripture reference like [Luke 2:12, 16](accord://read/?Luke 2:12, 16) should be clickable."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"%20"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)