#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:0\.(?:0[1-9]|[1-9]\d?)|[1-9]\d*(?:\.\d{1,2})?)(?:e[+-]?\d+)?$"
Local $sString = "0.1" & @CRLF & _
"0.01" & @CRLF & _
"0.10" & @CRLF & _
"0.1e34" & @CRLF & _
"0.1e+3" & @CRLF & _
"0.1E-2" & @CRLF & _
"1.00e3" & @CRLF & _
"1.00" & @CRLF & _
"23.45" & @CRLF & _
"2e34" & @CRLF & _
"" & @CRLF & _
"invalid" & @CRLF & _
"0" & @CRLF & _
"0.001" & @CRLF & _
"12.234" & @CRLF & _
"0e34" & @CRLF & _
"-1" & @CRLF & _
"0.1f45" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")