// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:0\.(?:0[1-9]|[1-9]\d?)|[1-9]\d*(?:\.\d{1,2})?)(?:e[+-]?\d+)?$").unwrap();
let string = "0.1
0.01
0.10
0.1e34
0.1e+3
0.1E-2
1.00e3
1.00
23.45
2e34
invalid
0
0.001
12.234
0e34
-1
0.1f45
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}