$re = '/^(?:0\.(?:0[1-9]|[1-9]\d?)|[1-9]\d*(?:\.\d{1,2})?)(?:e[+-]?\d+)?$/mi';
$str = '0.1
0.01
0.10
0.1e34
0.1e+3
0.1E-2
1.00e3
1.00
23.45
2e34
invalid
0
0.001
12.234
0e34
-1
0.1f45
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);