import re
regex = re.compile(r"^(?:0\.(?:0[1-9]|[1-9]\d?)|[1-9]\d*(?:\.\d{1,2})?)(?:e[+-]?\d+)?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("0.1\n"
"0.01\n"
"0.10\n"
"0.1e34\n"
"0.1e+3\n"
"0.1E-2\n"
"1.00e3\n"
"1.00\n"
"23.45\n"
"2e34\n\n"
"invalid\n"
"0\n"
"0.001\n"
"12.234\n"
"0e34\n"
"-1\n"
"0.1f45\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")