package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([ก-ฮ]{1,3}\d{1,4})|\d{1}([ก-ฮ]{1,3}\d{1,4})`)
var str = `กข1234
กข123
กข12
กข1
กขค1234
กขค123
กขค12
กขค1
1กข1234
1กข123
1กข12
1กข1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}