import re
regex = re.compile(r"([ก-ฮ]{1,3}\d{1,4})|\d{1}([ก-ฮ]{1,3}\d{1,4})")
test_str = ("กข1234\n"
"กข123\n"
"กข12\n"
"กข1\n"
"กขค1234\n"
"กขค123\n"
"กขค12\n"
"กขค1\n"
"1กข1234\n"
"1กข123\n"
"1กข12\n"
"1กข1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")