$re = '/([ก-ฮ]{1,3}\d{1,4})|\d{1}([ก-ฮ]{1,3}\d{1,4})/';
$str = 'กข1234
กข123
กข12
กข1
กขค1234
กขค123
กขค12
กขค1
1กข1234
1กข123
1กข12
1กข1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);