import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([ก-ฮ]{1,3}\\d{1,4})|\\d{1}([ก-ฮ]{1,3}\\d{1,4})";
final String string = "กข1234\n"
+ "กข123\n"
+ "กข12\n"
+ "กข1\n"
+ "กขค1234\n"
+ "กขค123\n"
+ "กขค12\n"
+ "กขค1\n"
+ "1กข1234\n"
+ "1กข123\n"
+ "1กข12\n"
+ "1กข1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}