// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([ก-ฮ]{1,3}\d{1,4})|\d{1}([ก-ฮ]{1,3}\d{1,4})").unwrap();
let string = "กข1234
กข123
กข12
กข1
กขค1234
กขค123
กขค12
กขค1
1กข1234
1กข123
1กข12
1กข1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}