using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\b(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})\b.*";
string substitution = @"\1.\2.\3.\4";
string input = @"ip-10-179-50-22.corp.dept.org.uk";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}