# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\b(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})\b.*"
test_str = "ip-10-179-50-22.corp.dept.org.uk"
subst = "\\1.\\2.\\3.\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.