re = /.*\b(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})\b.*/m
str = 'ip-10-179-50-22.corp.dept.org.uk'
subst = '\\1.\\2.\\3.\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result