import Foundation
let pattern = #".*\b(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})\b.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ip-10-179-50-22.corp.dept.org.uk"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1.\2.\3.\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)