use strict;
my $str = 'ip-10-179-50-22.corp.dept.org.uk';
my $regex = qr/.*\b(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})\b.*/mp;
my $subst = '\\1.\\2.\\3.\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";