package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\b(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})\b.*`)
var str = `ip-10-179-50-22.corp.dept.org.uk`
var substitution = "\1.\2.\3.\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}