using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^-]+)-([^-]+)$";
string substitution = @"$1_$2";
string input = @"abcd-12=jksjd-jkkj
xyzm-87=hjahf-tyewg
zaqw-99=poiuy-12hd";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}