$re = '/([^-]+)-([^-]+)$/m';
$str = 'abcd-12=jksjd-jkkj
xyzm-87=hjahf-tyewg
zaqw-99=poiuy-12hd';
$subst = "$1_$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;