// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^-]+)-([^-]+)$").unwrap();
let string = "abcd-12=jksjd-jkkj
xyzm-87=hjahf-tyewg
zaqw-99=poiuy-12hd";
let substitution = "$1_$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}