# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^-]+)-([^-]+)$"
test_str = ("abcd-12=jksjd-jkkj\n"
"xyzm-87=hjahf-tyewg\n"
"zaqw-99=poiuy-12hd")
subst = "$1_$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.