package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^-]+)-([^-]+)$`)
var str = `abcd-12=jksjd-jkkj
xyzm-87=hjahf-tyewg
zaqw-99=poiuy-12hd`
var substitution = "$1_$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}