use strict;
my $str = 'abcd-12=jksjd-jkkj
xyzm-87=hjahf-tyewg
zaqw-99=poiuy-12hd';
my $regex = qr/([^-]+)-([^-]+)$/mp;
my $subst = '$1_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";