# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)(?:^([^"]*(?:"[^"a]*(?=")"[^"]*(?="))*"[^"a]*)|(?!^)\G)a([^"a]*(?:(?=a.*?")|(?:"[^"]*$|"[^"]*(?=")(?:"[^"a]*(?=")"[^"]*(?="))*"[^"a]*)))/$1b$2/g;t' <<< "Somebody once told me \"apples\" are good for you
=> Somebody once told me \"bpples\" are good for you
\"Aardvarks\" make good kebabs
=> \"Abrdvbrks\" make good kebabs
The boy said \"aaah!\" when his mom told him he was eating aardvark
=> The boy said \"bbbh!\" when his mom told him he was eating aardvark
"